Skip to main content
VulnerabilityPublished

CVE-2026-30979: InternationalColorConsortium iccDEV · Classic Buffer Overflow

Affects InternationalColorConsortium iccDEVSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 2.3.1.5 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.1.5
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade iccDEV and internationalcolorconsortium/iccDEV to 2.3.1.5.

Affected software

ProductAffectedFixed in
InternationalColorConsortiumiccDEVAffected
  • <2.3.1.5
Fixed in
  • 2.3.1.5
GitHubinternationalcolorconsortium/iccDEVpkg:github/internationalcolorconsortium/iccDEVOther threatsAffected
  • <2.3.1.5
Fixed in
  • 2.3.1.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade all instances of iccDEV to version 2.3.1.5 or later immediately to apply the official patch.
  2. Restrict local user permissions to only those necessary, minimizing the risk of untrusted users triggering the vulnerability.
  3. Implement application whitelisting and endpoint protection to detect and block anomalous behavior related to iccDEV processes.
  4. Monitor system logs and application behavior for signs of memory corruption or crashes linked to iccDEV usage.
  5. Conduct regular security audits and user access reviews to identify and limit potential insider threats.
  6. If upgrading is not immediately possible, consider isolating systems running vulnerable versions and limiting user interaction with iccDEV tools.
  7. Educate users about the risks of interacting with untrusted files or inputs that may trigger the vulnerable function.

Description

CVE-2026-30979 is a high-severity heap-based buffer overflow vulnerability in the InternationalColorConsortium's iccDEV library versions prior to 2.3.1.5. The flaw exists in the CIccCalculatorFunc::InitSelectOp() function and can be triggered by local user interaction, leading to memory corruption, crashes, and potentially arbitrary code execution. Exploitation requires local access and user interaction but does not require prior privileges. The vulnerability impacts confidentiality, integrity, and availability due to the possibility of executing malicious code or causing denial of service. No known exploits are currently reported in the wild. The issue is fixed in version 2.3.

References

Community reviews

Loading reviews…