Skip to main content
VulnerabilityPublished Updated

CVE-2026-31732: Linux kernel · gpio: Fix resource leaks on errors in gpiochip_add_data_with_key()

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium : upgrade to 7.0.0-1006.6 when convenient.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1006.6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to 7.0.0-1006.6.

Affected software

ProductAffectedFixed in
linux-hwe-edgeAffected
  • <7.0.0-1006.6
Fixed in
  • 7.0.0-1006.6

AI-suggested

An official patch is available that fixes the resource leak by properly managing reference counts and error handling in gpiochip_add_data_with_key(). Users should update affected Linux kernel versions to 7.0.0-1006.6 or later to remediate this issue. No additional mitigations are indicated by the vendor advisory.

Description

A resource leak vulnerability in the Linux kernel's gpio subsystem was fixed in gpiochip_add_data_with_key(). The issue arises because the device release callback was unset, causing reference counts not to be dropped on error paths, leading to resource leaks. The fix involves properly dropping references on errors and reordering instructions to simplify error handling. This vulnerability affects Linux kernel versions prior to 7.0.0-1006.6 and has a medium severity rating with a CVSS score of 5.5.

References

Community reviews

Loading reviews…