Skip to main content
VulnerabilityPublished Updated

CVE-2026-31868: parse-server · Cross-site Scripting

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 9.6.0-alpha.4 or 8.6.30 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.4, 8.6.30
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.4 or 8.6.30; parse-server to 8.6.30.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.4
Fixed in
  • 9.6.0-alpha.4
parse-communityparse-serverAffected
  • <8.6.30
Fixed in
  • 8.6.30
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • <8.6.30
Fixed in
  • 8.6.30

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 9.6.0-alpha.4 or later, or 8.6.30 or later, where the vulnerability is fixed. In addition to patching, administrators should review and harden the fileUpload.fileExtensions configuration to explicitly block all potentially dangerous file types beyond those already blocked, including .svgz, .xht, .xml, .xsl, and .xslt, and any other XML-based or scriptable file formats. Implement strict content-type validation on uploads and consider using server-side scanning or sanitization tools to detect and neutralize embedded scripts in uploaded files. Restrict file upload permissions to trusted users where possible and monitor upload logs for suspicious activity. Employ Content Security Policy (CSP) headers to limit the impact of any injected scripts. Educate users to avoid clicking on untrusted links that may lead to malicious file URLs. Finally, conduct regular security assessments and penetration testing focused on file upload functionality to detect similar issues proactively.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.4 and 8.6.30, an attacker can upload a file with a file extension or content type that is not blocked by the default configuration of the Parse Server fileUpload.fileExtensions option. The file can contain malicious code, for example JavaScript in an SVG or XHTML file. When the file is accessed via its URL, the browser renders the file and executes the malicious code in the context of the Parse Server domain. This is a stored Cross-Site Scripting (XSS) vulnerability that can be exploited to steal session tokens, redirect users, or perform actions on behalf of other users. Affected file extensions and content types include .svgz, .xht, .xml, .xsl, .xslt, and content types application/xhtml+xml and application/xslt+xml for extensionless uploads. Uploading of .html, .htm, .shtml, .xhtml, and .svg files was already blocked. This vulnerability is fixed in 9.6.0-alpha.4 and 8.6.30.

References

Community reviews

Loading reviews…