Skip to main content
VulnerabilityPublished Updated

CVE-2026-31871: parse-server · SQL Injection

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 9.6.0-alpha.5 or 8.6.31 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.5, 8.6.31
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.5 or 8.6.31; parse-community/parse-server to 8.6.31.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.5
Fixed in
  • 9.6.0-alpha.5
parse-communityparse-serverAffected
  • <8.6.31
Fixed in
  • 8.6.31
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.31
Fixed in
  • 8.6.31

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-31871, organizations should immediately upgrade parse-server to versions 9.6.0-alpha.5 or 8.6.31 or later, where the vulnerability is patched. If upgrading is not immediately feasible, implement strict input validation and sanitization on client-side and server-side to reject or escape sub-key names containing special characters such as single quotes. Restrict write access to the Parse Server REST API to trusted and authenticated clients only, using network-level controls like IP whitelisting and API gateways. Monitor logs for suspicious Increment operations involving nested object fields with unusual characters. Employ database-level security measures such as role-based access controls and query logging to detect and prevent unauthorized SQL commands. Conduct regular security audits and penetration testing focusing on injection flaws in custom API endpoints. Finally, maintain an incident response plan to quickly address any signs of exploitation.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.5 and 8.6.31, a SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The sub-key name is interpolated directly into SQL string literals without escaping. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL via a crafted sub-key name containing single quotes, potentially executing commands or reading data from the database, bypassing CLPs and ACLs. Only Postgres deployments are affected. This vulnerability is fixed in 9.6.0-alpha.5 and 8.6.31.

References

Community reviews

Loading reviews…