Skip to main content
VulnerabilityPublished Updated

CVE-2026-31872: parse-server · Improper Access Control

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 9.6.0-alpha.6 or 8.6.32 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.6, 8.6.32
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.6 or 8.6.32; parse-community/parse-server to 8.6.32.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.6
Fixed in
  • 9.6.0-alpha.6
parse-communityparse-serverAffected
  • <8.6.32
Fixed in
  • 8.6.32
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.32
  • =9.6.0-alpha.6
Fixed in
  • 8.6.32

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 9.6.0-alpha.6 or later, or 8.6.32 or later, where the vulnerability is patched. Until upgrades can be applied, administrators should audit and restrict network access to parse-server instances, limiting exposure to trusted networks or VPNs. Review and tighten class-level permissions and protectedFields configurations to minimize sensitive data exposure. Implement monitoring and alerting for unusual query patterns that may indicate exploitation attempts involving dot-notation queries or sorting. Consider deploying web application firewalls (WAFs) with custom rules to detect and block suspicious query parameters using dot-notation. Conduct thorough security testing and code reviews on custom parse-server extensions or cloud functions that may interact with protected fields. Maintain an incident response plan to quickly address any suspected data leakage. Finally, keep parse-server and its dependencies regularly updated to incorporate security fixes.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.6 and 8.6.32, the protectedFields class-level permission (CLP) can be bypassed using dot-notation in query WHERE clauses and sort parameters. An attacker can use dot-notation to query or sort by sub-fields of a protected field, enabling a binary oracle attack to enumerate protected field values. This affects both MongoDB and PostgreSQL deployments. This vulnerability is fixed in 9.6.0-alpha.6 and 8.6.32.

References

Community reviews

Loading reviews…