CVE-2026-31955: xibosignage xibo-cms · Server-Side Request Forgery (SSRF)
Affects xibosignage xibo-cmsSource CVE Database V5
Not known to be exploited · CVSS 4.9 Medium : upgrade to 4.4.1 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade xibo-cms and xibosignage/xibo-cms to 4.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| xibosignagexibo-cms | Affected
| Fixed in
|
GitHubxibosignage/xibo-cmspkg:github/xibosignage/xibo-cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 4.4.1 of xibo-cms is available and upgrading to this version is necessary to remediate the vulnerability. Since xibo-cms is a cloud-hosted service, the vendor manages remediation server-side, so users should verify with the vendor that their instance is updated. For users unable to upgrade immediately, it is recommended to revoke DataSet permissions from any users who are not fully trusted, as these privileges are required to exploit the vulnerability. No additional mitigations are indicated by the vendor advisory.
Description
Xibo is an open source digital signage platform with a web content management system and Windows display player software. An authenticated Server-Side Request Forgery (SSRF) vulnerability in versions prior to 4.4.1 allows users with DataSet permissions to make arbitrary HTTP requests from the CMS server to internal or external network resources. This can be exploited to scan internal infrastructure, access local cloud metadata endpoints (e.g., AWS IMDS), interact with internal services that lack authentication, or exfiltrate data. Exploitation of the vulnerability is possible on behalf of an authorized user who has both of the following privileges, which are not granted to non-admins as standard: Include "Add DataSet" button to allow for additional DataSets to be created independently to Layouts. Users should upgrade to version 4.4.1 which fixes this issue. Upgrading to a fixed version is necessary to remediate. Users unable to upgrade should revoke such privileges from users they do not trust.