Skip to main content
VulnerabilityPublished

CVE-2026-32100: swag platform-security · Information Exposure

Affects swag platform-securitySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · fixed in 4.0.7 : update swag platform-security when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.7, 3.0.12, 2.0.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade platform-security to 4.0.7, 3.0.12 or 2.0.16; shopware/platform-security to 3.0.12 or 2.0.16.

Affected software

ProductAffectedFixed in
swagplatform-securityAffected
  • >=4.0.0 <4.0.7
Fixed in
  • 4.0.7
swagplatform-securityAffected
  • >=3.0.0 <3.0.12
Fixed in
  • 3.0.12
swagplatform-securityAffected
  • <2.0.16
Fixed in
  • 2.0.16
GitHubshopware/platform-securitypkg:github/shopware/platform-securityOther threatsAffected
  • <2.0.16
  • >=3.0.0 <3.0.12
Fixed in
  • 2.0.16
  • 3.0.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-32100, organizations should promptly upgrade affected Shopware installations to versions 2.0.16, 3.0.12, 4.0.7, or later, where the vulnerability has been addressed. If immediate upgrading is not feasible, restrict access to the /api/_info/config endpoint by implementing network-level controls such as firewall rules, IP whitelisting, or VPN access to limit exposure to trusted users only. Additionally, consider implementing API gateway policies or web application firewall (WAF) rules to block or monitor requests to this endpoint. Review and minimize the amount of sensitive information exposed via public APIs, following the principle of least privilege and information disclosure. Regularly audit API endpoints for unintended data exposure and apply security hardening best practices. Monitoring logs for unusual access patterns to this endpoint can help detect reconnaissance attempts. Finally, maintain an up-to-date inventory of Shopware versions deployed across the organization to ensure timely patch management and vulnerability remediation.

Description

CVE-2026-32100 is a medium severity vulnerability in the Shopware open commerce platform's swag platform-security component. The /api/_info/config API endpoint exposes sensitive information about active security fixes without requiring authentication. This information disclosure could aid attackers in identifying unpatched vulnerabilities. The issue affects versions prior to 2.0.16, 3.0.12, and 4.0.7 and has a CVSS score of 5.

References

Community reviews

Loading reviews…