Skip to main content
VulnerabilityPublished

CVE-2026-32242: parse-server · Race Condition

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 9.6.0-alpha.11 or 8.6.37 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.11, 8.6.37
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.11 or 8.6.37; parse-community/parse-server to 8.6.37.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.11
Fixed in
  • 9.6.0-alpha.11
parse-communityparse-serverAffected
  • <8.6.37
Fixed in
  • 8.6.37
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.37
  • =9.6.0-alpha.11
Fixed in
  • 8.6.37

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 9.6.0-alpha.11 or later, or 8.6.37 or later, where the race condition has been fixed. Until upgrades are applied, deployments should avoid configuring multiple OAuth2 providers simultaneously with the oauth2: true flag to reduce exposure. Implementing additional application-level synchronization or request serialization around OAuth2 token validation may help mitigate concurrent execution issues temporarily. Security teams should audit OAuth2 configurations and monitor authentication logs for anomalies indicating token validation inconsistencies. Employing runtime application self-protection (RASP) or Web Application Firewalls (WAFs) with custom rules to detect unusual OAuth2 token usage patterns can provide additional defense. Finally, ensure that all dependencies and third-party libraries are kept up to date and conduct regular security testing focused on authentication mechanisms.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.11 and 8.6.37, Parse Server's built-in OAuth2 auth adapter exports a singleton instance that is reused directly across all OAuth2 provider configurations. Under concurrent authentication requests for different OAuth2 providers, one provider's token validation may execute using another provider's configuration, potentially allowing a token that should be rejected by one provider to be accepted because it is validated against a different provider's policy. Deployments that configure multiple OAuth2 providers via the oauth2: true flag are affected. This vulnerability is fixed in 9.6.0-alpha.11 and 8.6.37.

References

Community reviews

Loading reviews…