CVE-2026-32248: parse-server · Improper Neutralization of Special Elements in Data Query Logic
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 9.6.0-alpha.12 or 8.6.38 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.12, 8.6.38
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.12 or 8.6.38; parse-community/parse-server to 8.6.38.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade parse-server to version 9.6.0-alpha.12 or later, or 8.6.38 or later, where the vulnerability is fixed. If upgrading is not immediately feasible, disable anonymous authentication to prevent exploitation via unvalidated user identifiers. Review and enforce strict validation of user identifiers for all authentication providers to ensure only exact-match queries are performed. Implement additional monitoring and alerting for unusual login patterns or session token issuance to detect potential exploitation attempts. Conduct thorough audits of user accounts created via anonymous or other non-validated authentication methods and consider resetting session tokens or passwords where appropriate. Employ network-level protections such as web application firewalls (WAFs) to detect and block suspicious query patterns targeting the login endpoint. Educate development teams on secure query construction and input validation to prevent similar injection or query manipulation vulnerabilities. Maintain an up-to-date inventory of parse-server deployments and their versions to prioritize patching efforts. Finally, integrate vulnerability scanning and penetration testing focused on authentication mechanisms to identify residual risks.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0 and 8.6.38.