Skip to main content
VulnerabilityPublished

CVE-2026-32279: opensource-workshop connect-cms · Server-Side Request Forgery (SSRF)

Affects opensource-workshop connect-cmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.8 Medium : upgrade to 2.41.1 or 1.41.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.41.1, 1.41.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade connect-cms and opensource-workshop/connect-cms to 2.41.1 or 1.41.1.

Affected software

ProductAffectedFixed in
opensource-workshopconnect-cmsAffected
  • >=2.0.0 <2.41.1
Fixed in
  • 2.41.1
opensource-workshopconnect-cmsAffected
  • <1.41.1
Fixed in
  • 1.41.1
GitHubopensource-workshop/connect-cmspkg:github/opensource-workshop/connect-cmsOther threatsAffected
  • <1.41.1
  • <2.41.1
Fixed in
  • 1.41.1
  • 2.41.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-32279, organizations should immediately upgrade Connect-CMS installations to versions 1.41.1 or 2.41.1 or later, where the SSRF vulnerability has been patched. In addition to patching, administrators should review and restrict access to the Page Management Plugin’s external page migration feature, limiting its use to trusted administrators only. Implement strict network segmentation and firewall rules to prevent the Connect-CMS server from making unauthorized outbound requests to internal or sensitive network segments. Employ web application firewalls (WAFs) with SSRF detection capabilities to monitor and block suspicious outbound requests originating from the CMS server. Conduct regular audits of user privileges to ensure that only necessary users have high-level access, reducing the risk of insider exploitation. Monitoring logs for unusual server-side request patterns can help detect attempted SSRF exploitation. Finally, consider disabling or restricting the external page migration feature if it is not essential to operational workflows, thereby reducing the attack surface.

Description

Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Server-Side Request Forgery (SSRF) issue exists in the external page migration feature of the Page Management Plugin. Versions 1.41.1 and 2.41.1 contain a patch.

References

Community reviews

Loading reviews…