CVE-2026-32600: simplesamlphp xml-security · Improper Validation of Integrity Check Value
Affects simplesamlphp xml-securitySource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 2.3.1 or 1.13.9 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.1, 1.13.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade xml-security to 2.3.1 or 1.13.9; simplesamlphp/xml-security to 1.13.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| simplesamlphpxml-security | Affected
| Fixed in
|
| simplesamlphpxml-security | Affected
| Fixed in
|
GitHubsimplesamlphp/xml-securitypkg:github/simplesamlphp/xml-securityOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade the simplesamlphp xml-security library to version 2.3.1 or 1.13.9 or later, where the vulnerability is patched. Prior to upgrading, conduct an inventory of all systems using simplesamlphp to identify affected versions. Implement network-level protections such as restricting access to SAML endpoints to trusted IP ranges and deploying web application firewalls (WAFs) with rules to detect anomalous XML payloads. Monitor authentication logs and XML processing events for unusual patterns that may indicate exploitation attempts. Where possible, employ additional encryption or tokenization layers around sensitive XML data to reduce exposure. Conduct thorough security testing and code reviews of SAML integrations to ensure no residual weaknesses exist. Finally, maintain an incident response plan tailored to identity federation breaches to quickly respond if exploitation is detected.
Description
xml-security is a library that implements XML signatures and encryption. Prior to versions 2.3.1 and 1.13.9, XML nodes encrypted with either aes-128-gcm, aes-192-gcm, or aes-256-gcm lack validation of the authentication tag length. An attacker can use this to brute-force an authentication tag, recover the GHASH key, and decrypt the encrypted nodes. It also allows to forge arbitrary ciphertexts without knowing the encryption key. This vulnerability is fixed in 2.3.1 and 1.13.9.
References
- github.com/simplesamlphp/xml-security/security/advisories/GHSA-r353-4845-pr5p (opens in a new tab)
- github.com/simplesamlphp/xml-security/commit/cad6d57cf0a5a0b7e0cc4e4a5b18752e56eb1520 (opens in a new tab)
- github.com/simplesamlphp/xml-security/commit/fdc12449e959c610943f9fd428e95e3832d74c25 (opens in a new tab)