CVE-2026-32629: thorsten phpMyFAQ · Improper Input Validation
Affects thorsten phpMyFAQSource CVE Database V5
Public exploit available · CVSS 5.4 Medium : upgrade to 4.1.1 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade phpMyFAQ and thorsten/phpMyFAQ to 4.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| thorstenphpMyFAQ | Affected
| Fixed in
|
GitHubthorsten/phpMyFAQpkg:github/thorsten/phpMyFAQOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade phpMyFAQ to version 4.1.1 or later, where this vulnerability has been patched. The vendor has fixed the issue by properly sanitizing email inputs and avoiding unsafe rendering with Twig's |raw filter. No additional mitigation is required if the system is updated.
Description
phpMyFAQ versions prior to 4.1.1 contain an input validation vulnerability where an unauthenticated attacker can submit a guest FAQ with an email address that includes raw HTML. The email passes PHP's FILTER_VALIDATE_EMAIL but is stored without HTML sanitization and rendered with Twig's |raw filter, bypassing auto-escaping. This can lead to cross-site scripting (XSS) in the admin FAQ editor. The issue is fixed in version 4.1.1.