Skip to main content
VulnerabilityPublished Updated

CVE-2026-32647: F5 NGINX Open Source · Out-of-bounds Read

Affects F5 NGINX Open SourceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 1.29.7 or 1.28.3 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.29.7, 1.28.3, R36 P3 +2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade NGINX to 1.29.7 or 1.28.3 (Open Source); R36 P3, R35 P2 or R32 P5 (Plus).

Affected software

ProductAffectedFixed in
F5NGINX Open SourceAffected
  • >=1.29.0 <1.29.7
Fixed in
  • 1.29.7
F5NGINX Open SourceAffected
  • >=1.1.19 <1.28.3
Fixed in
  • 1.28.3
F5NGINX PlusAffected
  • >=R34
  • >=R33
  • =R36
  • =R35
  • =R32
Fixed in
  • R36 P3
  • R35 P2
  • R32 P5

AI-suggested

Red Hat has released security updates that fix this vulnerability in their NGINX packages for Red Hat Enterprise Linux 10.0 Extended Update Support. Users should apply these official patches as detailed in the Red Hat advisories (e.g., RHSA-2026:13634). Since this is not a cloud service, remediation depends on applying vendor-provided updates. Patch status is confirmed by Red Hat advisories. No indication of 'no action required' or 'already mitigated' is present, so applying the update is recommended.

Description

NGINX Open Source and NGINX Plus have a vulnerability in the ngx_http_mp4_module module, which might allow an attacker to trigger a buffer over-read or over-write to the NGINX worker memory resulting in its termination or possibly code execution, using a specially crafted MP4 file. This issue affects NGINX Open Source and NGINX Plus if it is built with the ngx_http_mp4_module module and the mp4 directive is used in the configuration file. Additionally, the attack is possible only if an attacker can trigger the processing of a specially crafted MP4 file with the ngx_http_mp4_module module. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…