Skip to main content
VulnerabilityPublished Updated

CVE-2026-32721: openwrt luci · Cross-site Scripting

Affects openwrt luciSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 26.072.65753~068150b soon.

Data as of 1 Nov 2026, 08:20 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.072.65753~068150b, 25.12.1, 24.10.6 +2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade luci to 26.072.65753~068150b; openwrt to 25.12.1 or 24.10.6; openwrt/luci to 25.12.0 or 24.10.5.

Affected software

ProductAffectedFixed in
openwrtluciAffected
  • <26.072.65753~068150b
Fixed in
  • 26.072.65753~068150b
openwrtopenwrtAffected
  • >=25.12.0 <25.12.1
Fixed in
  • 25.12.1
openwrtopenwrtAffected
  • <24.10.6
Fixed in
  • 24.10.6
GitHubopenwrt/lucipkg:github/openwrt/luciOther threatsAffected
  • <24.10.5
  • <25.12.0
  • >23.05 <=24.10.6
  • >22.03 <=25.12.1
Fixed in
  • 24.10.5
  • 25.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Administrators should immediately upgrade affected OpenWrt devices to LuCI version 26.072.65753~068150b or later, where the vulnerability is patched. If upgrading is not immediately possible, network administrators should restrict access to the LuCI interface to trusted networks only and disable wireless scanning features that trigger the vulnerable code path. Implement network segmentation to isolate management interfaces from untrusted wireless networks. Users should be educated to avoid opening the wireless scan modal in untrusted environments. Additionally, monitoring for unusual SSIDs and logging access to the LuCI interface can help detect potential exploitation attempts. Applying Content Security Policy (CSP) headers on the LuCI interface could provide an additional layer of defense against XSS exploitation. Vendors and integrators should review their firmware builds to ensure the patched LuCI version is included in future releases.

Description

LuCI is the OpenWrt Configuration Interface. Versions prior to both 24.10.5 and 25.12.0, contain a stored XSS vulnerability in the wireless scan modal, where SSID values from scan results are rendered as raw HTML without any sanitization. The wireless.js file in the luci-mod-network package passes SSIDs via a template literal to dom.append(), which processes them through innerHTML, allowing an attacker to craft a malicious SSID containing arbitrary HTML/JavaScript. Exploitation requires the user to actively open the wireless scan modal (e.g., to connect to a Wi-Fi access point or survey nearby channels), and only affects OpenWrt versions newer than 23.05/22.03 up to the patched releases (24.10.6 and 25.12.1). The issue has been fixed in version LuCI 26.072.65753~068150b.

References

Community reviews

Loading reviews…