Skip to main content
VulnerabilityPublished

CVE-2026-32731: apostrophecms import-export · Path Traversal

Affects apostrophecms import-exportSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 10.0 Critical : upgrade to 3.5.3 as a priority.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade import-export and apostrophecms/import-export to 3.5.3.

Affected software

ProductAffectedFixed in
apostrophecmsimport-exportAffected
  • <3.5.3
Fixed in
  • 3.5.3
npmapostrophecms/import-exportpkg:npm/apostrophecms/import-exportOther threatsAffected
  • <3.5.3
Fixed in
  • 3.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade the @apostrophecms/import-export module to version 3.5.3 or later, where the vulnerability is fixed. Until the upgrade is applied, restrict the assignment of the Global Content Modify permission to only trusted users and audit existing roles to minimize exposure. Implement strict input validation and sanitization on uploaded archive files if possible, including rejecting archives containing path traversal sequences. Employ runtime security controls such as filesystem access restrictions and containerization to limit the Node.js process's filesystem permissions, preventing writes outside designated directories. Monitor logs for suspicious import activities and unexpected file modifications. Additionally, conduct regular security reviews of user permissions and apply the principle of least privilege to reduce the attack surface. Consider deploying web application firewalls (WAFs) with rules to detect and block malicious archive uploads.

Description

CVE-2026-32731 is a critical path traversal vulnerability in ApostropheCMS's import-export module prior to version 3.5.3. The vulnerability arises because the extract() function in gzip.js uses path.join() without sanitizing or resolving traversal sequences like '.. /', allowing crafted tar.gz files to write files outside the intended directory. Any user with Global Content Modify permission, typically content editors or site managers, can exploit this by uploading a malicious archive via the CMS import UI. This can lead to arbitrary file writes anywhere the Node.

References

Community reviews

Loading reviews…