Skip to main content
VulnerabilityPublished

CVE-2026-32770: parse-server · Uncaught Exception

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 9.6.0-alpha.19 or 8.6.43 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.19, 8.6.43
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.19 or 8.6.43; parse-community/parse-server to 8.6.43.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.19
Fixed in
  • 9.6.0-alpha.19
parse-communityparse-serverAffected
  • <8.6.43
Fixed in
  • 8.6.43
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.43
Fixed in
  • 8.6.43

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations should upgrade parse-server to version 9.6.0-alpha.19 or later, or 8.6.43 or later, where the issue is fixed. If upgrading immediately is not feasible, disabling the LiveQuery feature entirely is a practical workaround to prevent exploitation. Additionally, organizations should implement input validation and sanitization controls on client inputs that interact with LiveQuery subscriptions to block malformed regex patterns before they reach the server. Monitoring server logs for unexpected crashes or regex-related errors can help detect attempted exploitation. Employing runtime protections such as Node.js process supervisors (e.g., PM2) can automatically restart the server if it crashes, reducing downtime. Finally, applying network-level protections to restrict access to the parse-server LiveQuery endpoint to trusted clients can reduce exposure to remote attacks.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0 and 8.6.43, a remote attacker can crash the Parse Server by subscribing to a LiveQuery with an invalid regular expression pattern. The server process terminates when the invalid pattern reaches the regex engine during subscription matching, causing denial of service for all connected clients. The fix in 9.6.0 and 8.6.43 validates regular expression patterns at subscription time, rejecting invalid patterns before they are stored. Additionally, a defense-in-depth try-catch prevents any subscription matching error from crashing the server process. As a workaround, disable LiveQuery if it is not needed.

References

Community reviews

Loading reviews…