Skip to main content
VulnerabilityPublished

CVE-2026-32890: openVESSL Anchorr · Cross-site Scripting

Affects openVESSL AnchorrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.7 Critical : upgrade to 1.4.2 as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
9.7Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade Anchorr and openvessl/Anchorr to 1.4.2.

Affected software

ProductAffectedFixed in
openVESSLAnchorrAffected
  • <1.4.2
Fixed in
  • 1.4.2
GitHubopenvessl/Anchorrpkg:github/openvessl/AnchorrOther threatsAffected
  • <1.4.2
Fixed in
  • 1.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations should immediately upgrade Anchorr to version 1.4.2 or later, which contains the necessary input sanitization and access control fixes. Until the upgrade is applied, restrict access to the Anchorr web dashboard strictly to trusted administrators and minimize the number of users in the configured Discord guild who can interact with the bot. Implement network-level controls to limit access to the API endpoints, especially the GET /api/config endpoint, to authorized personnel only. Monitor Discord guild activity for suspicious behavior, particularly unexpected script injections or unusual admin browser activity. Employ Content Security Policy (CSP) headers on the Anchorr dashboard to reduce the impact of potential XSS attacks. Regularly audit and rotate all exposed credentials, including Discord tokens and API keys, after patching the vulnerability. Finally, educate administrators about the risks of interacting with untrusted content within the dashboard interface.

Description

CVE-2026-32890 is a critical stored Cross-site Scripting (XSS) vulnerability in the Anchorr Discord bot versions 1.4.1 and below. It allows any unprivileged Discord user within the configured guild to execute arbitrary JavaScript in the admin's browser via the web dashboard's User Mapping dropdown. By exploiting this XSS and chaining it with the GET /api/config endpoint, attackers can retrieve all sensitive credentials stored in Anchorr, including Discord tokens, API keys, JWT secrets, webhook secrets, and bcrypt password hashes, without authentication. This vulnerability affects confidentiality, integrity, and availability and has a CVSS score of 9.7. The issue is fixed in version 1.4.2.

References

Community reviews

Loading reviews…