Skip to main content
VulnerabilityPublished

CVE-2026-32891: openVESSL Anchorr · Basic XSS

Affects openVESSL AnchorrSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.4.2 as a priority.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Anchorr and openvessl/Anchorr to 1.4.2.

Affected software

ProductAffectedFixed in
openVESSLAnchorrAffected
  • <1.4.2
Fixed in
  • 1.4.2
GitHubopenvessl/Anchorrpkg:github/openvessl/AnchorrOther threatsAffected
  • <1.4.2
Fixed in
  • 1.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade Anchorr to version 1.4.2 or later to remediate this vulnerability. Until the upgrade is applied, restrict access to the Anchorr admin dashboard to trusted users and networks to minimize exposure. Implement Content Security Policy (CSP) headers to reduce the impact of potential XSS attacks by restricting script execution sources. Review and rotate all API keys and tokens exposed by the vulnerability, including those for Jellyfin, Jellyseerr, and Discord integrations, to invalidate any potentially compromised credentials. Conduct a thorough audit of logs and system activity to detect any signs of exploitation or unauthorized access. Educate users about the risks of injecting untrusted input and enforce strict input validation and sanitization in custom integrations. Additionally, consider isolating the Anchorr service and its integrations within segmented network zones to limit lateral movement in case of compromise.

Description

Anchorr is a Discord bot for requesting movies and TV shows and receiving notifications when items are added to a media server. Versions 1.4.1 and below contain a stored XSS vulnerability in the Jellyseerr user selector. Jellyseerr allows any account holder to execute arbitrary JavaScript in the Anchorr admin's browser session. The injected script calls the authenticated /api/config endpoint - which returns the full application configuration in plaintext. This allows the attacker to forge a valid Anchorr session token and gain full admin access to the dashboard with no knowledge of the admin password. The same response also exposes the API keys and tokens for every integrated service, resulting in simultaneous account takeover of the Jellyfin media server (via JELLYFIN_API_KEY), the Jellyseerr request manager (via JELLYSEERR_API_KEY), and the Discord bot (via DISCORD_TOKEN). This issue has been fixed in version 1.4.2.

References

Community reviews

Loading reviews…