Skip to main content
VulnerabilityPublished

CVE-2026-32966: Apache DolphinScheduler · Incorrect Authorization

Affects Apache DolphinSchedulerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.4.2 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache to 3.4.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache DolphinSchedulerAffected
  • <3.4.2
Fixed in
  • 3.4.2
MavenApache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-apipkg:maven/Apache Software Foundation/org.apache.dolphinscheduler:dolphinscheduler-apiOther threatsAffected
  • <3.4.2
Fixed in
  • 3.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache DolphinScheduler to version 3.4.2 or later, where this authorization issue has been fixed. Patch status is confirmed by the vendor advisory recommending the upgrade to 3.4.2.

Description

An authorization flaw in Apache DolphinScheduler before version 3.4.2 allows unauthorized users to access arbitrary data source metadata via the DataSource API. This vulnerability is identified as CWE-863 Incorrect Authorization. The issue is fixed in version 3.4.2.

References

Community reviews

Loading reviews…