CVE-2026-33029: 0xJacky nginx-ui · Improper Input Validation
Affects 0xJacky nginx-uiSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.3.4 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 62% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade nginx-ui and 0xjacky/nginx-ui to 2.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 0xJackynginx-ui | Affected
| Fixed in
|
GitHub0xjacky/nginx-uipkg:github/0xjacky/nginx-uiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade nginx-ui to version 2.3.4 or later, where this input validation vulnerability has been patched. No other mitigations are specified or required once the update is applied.
Description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, an input validation vulnerability in the logrotate configuration allows an authenticated user to cause a complete Denial of Service (DoS). By submitting a negative integer for the rotation interval, the backend enters an infinite loop or an invalid state, rendering the web interface unresponsive. This issue has been patched in version 2.3.4.