Skip to main content
VulnerabilityPublished

CVE-2026-33050: geonode · OS Command Injection

Affects geonodeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 5.1.0 soon.

Data as of 6 Nov 2026, 19:51 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.18.8
Patch
Available – fixed in 5.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade geonode to 5.1.0.

Affected software

ProductAffectedFixed in
GeoNodegeonodeAffected
  • <5.1.0
Fixed in
  • 5.1.0

AI-suggested

Upgrade GeoNode to version 5.1.0 or later, where this vulnerability is fixed. No other mitigation steps are indicated or required according to the vendor advisory.

Description

GeoNode versions prior to 5.1.0 contain an OS command injection vulnerability (CWE-78) that allows a low-privileged remote user to execute arbitrary operating system commands by supplying a crafted vector file layer name during upload. This vulnerability is fixed in GeoNode version 5.1.0.

References

Community reviews

Loading reviews…