CVE-2026-3315: ASSA ABLOY Visionline · Incorrect Default Permissions
Affects ASSA ABLOY VisionlineSource CVE Database V5
Not known to be exploited · CVSS 5.8 Medium : upgrade to 1.33 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.33
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L/AU:Y/R:U/RE:L/U:ClearExploitation evidence
Disclosed: evidence found.
CVE published 10 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ASSA ABLOY Visionline to 1.33.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ASSA ABLOYVisionline | Affected
| Fixed in
|
AI-suggested
Organizations should immediately identify and inventory all Visionline installations running affected versions (1.0 up to 1.33). Since no official patches are currently available, administrators should manually review and correct file system and resource permissions to ensure that only authorized users have access to configuration and environment settings. Implement strict access controls and audit logging on Visionline systems to detect unauthorized changes. Limit local access to trusted personnel only and consider isolating Visionline servers from general user networks. Monitor for unusual privilege escalations or configuration modifications. Engage with ASSA ABLOY for updates on patches or security advisories. Additionally, apply the principle of least privilege to all users and services interacting with Visionline, and consider deploying host-based intrusion detection systems to alert on suspicious activities related to configuration files or environment variables.
Description
CVE-2026-3315 is a medium severity vulnerability in ASSA ABLOY Visionline versions from 1.0 up to but not including 1.33 on Windows. It involves incorrect default permissions that allow execution with unnecessary privileges and incorrect permission assignments on critical resources. This misconfiguration enables attackers with limited privileges to manipulate configuration or environment settings, potentially escalating their privileges or impacting system integrity. Exploitation requires local access with low privileges and does not need user interaction. No known exploits are currently reported in the wild. The vulnerability affects Visionline installations primarily in physical security environments where this software is deployed. Organizations using affected versions should prioritize patching or applying mitigations to prevent unauthorized configuration changes that could compromise system security.