CVE-2026-33210: ruby json · Use of Externally-Controlled Format String
Affects ruby jsonSource CVE Database V5
Not known to be exploited · CVSS 8.3 High · fixed in 2.19.2 : patch ruby json soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.19.2, 2.17.1.2, 2.15.2.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade ruby json to 2.19.2, 2.17.1.2 or 2.15.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rubyjson | Affected
| Fixed in
|
| rubyjson | Affected
| Fixed in
|
| rubyjson | Affected
| Fixed in
|
RubyGemsjsonpkg:gem/jsonOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability has been officially patched in Ruby JSON versions 2.15.2.1, 2.17.1.2, and 2.19.2. Users should upgrade to these or later versions to remediate the issue. Red Hat has released updated ruby4.0 packages for Red Hat Enterprise Linux 10 and related distributions addressing this vulnerability. Applying these vendor-provided updates is the recommended remediation. Patch status is confirmed by vendor advisories.
Description
Ruby JSON is a JSON implementation for Ruby. From version 2.14.0 to before versions 2.15.2.1, 2.17.1.2, and 2.19.2, a format string injection vulnerability can lead to denial of service attacks or information disclosure, when the allow_duplicate_key: false parsing option is used to parse user supplied documents. This issue has been patched in versions 2.15.2.1, 2.17.1.2, and 2.19.2.
References
- github.com/ruby/json/security/advisories/GHSA-3m6g-2423-7cp3 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-33210 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2449871 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33210.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:20606 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:20596 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:57565 (opens in a new tab)