CVE-2026-33217: nats-server · Incorrect Authorization
Affects nats-serverSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 2.12.6 or 2.11.15 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.12.6, 2.11.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nats-server to 2.12.6 or 2.11.15; nats-io/nats-server to 2.11.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nats-ionats-server | Affected
| Fixed in
|
| nats-ionats-server | Affected
| Fixed in
|
GitHubnats-io/nats-serverpkg:github/nats-io/nats-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in nats-server versions 2.11.15 and 2.12.6. Users should upgrade to these or later versions to remediate the vulnerability. No known workarounds or mitigations are available that meet Red Hat's criteria for ease of use and applicability. Therefore, upgrading is the recommended and effective mitigation.
Description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, when using ACLs on message subjects, these ACLs were not applied in the `$MQTT.>` namespace, allowing MQTT clients to bypass ACL checks for MQTT subjects. Versions 2.11.15 and 2.12.6 contain a fix. No known workarounds are available.
References
- github.com/nats-io/nats-server/security/advisories/GHSA-jxxm-27vp-c3m5 (opens in a new tab)
- advisories.nats.io/CVE/secnote-2026-07.txt (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-33217 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2451446 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33217.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:22347 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:23345 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:21769 (opens in a new tab)