CVE-2026-33220: WeblateOrg weblate · Path Traversal
Affects WeblateOrg weblateSource CVE Database V5
Not known to be exploited · CVSS 6.8 Medium : upgrade to 5.17 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.17
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade WeblateOrg weblate to 5.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WeblateOrgweblate | Affected
| Fixed in
|
PyPIweblatepkg:pypi/weblateOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Weblate to version 5.17 or later, where this vulnerability is fixed. If immediate upgrading is not possible, disable the translation memory API feature as it is not enabled by default unless the CDN add-on is active. This effectively mitigates the risk until an official patch can be applied.
Description
CVE-2026-33220 is a medium severity vulnerability in Weblate versions prior to 5.17 involving improper limitation of a pathname to a restricted directory (path traversal) in the translation memory API. This flaw allowed access to unintended endpoints without proper access control. The issue has been fixed in Weblate version 5.17. Users unable to upgrade immediately can mitigate risk by disabling the translation memory API feature, which is not enabled by default unless the CDN add-on is used.