CVE-2026-33285: harttle liquidjs · Improper Input Validation
Affects harttle liquidjsSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 10.25.1 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.25.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade harttle liquidjs to 10.25.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| harttleliquidjs | Affected
| Fixed in
|
npmliquidjspkg:npm/liquidjsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade LiquidJS to version 10.25.1 or later, where this vulnerability is patched. No other mitigations are indicated or necessary once the update is applied.
Description
CVE-2026-33285 is a high-severity vulnerability in the LiquidJS template engine prior to version 10.25.1. The issue involves improper input validation allowing the memoryLimit security mechanism to be bypassed using reverse range expressions. This can lead to unlimited memory allocation and a subsequent V8 fatal error that crashes the Node.js process, causing a denial of service. The vulnerability is patched in LiquidJS version 10.25.1.