Skip to main content
CVE-2026-33498VulnerabilityPublished Updated

CVE-2026-33498: parse-server · Uncontrolled Recursion

Affects parse-serverSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.7 High : upgrade to 9.6.0-alpha.44 or 8.6.55 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.44, 8.6.55
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade parse-server to 9.6.0-alpha.44 or 8.6.55; parse-community/parse-server to 8.6.55.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • <8.6.55
  • >=9.0.0 <9.6.0-alpha.44
Fixed in
  • 9.6.0-alpha.44
  • 8.6.55
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.55
Fixed in
  • 8.6.55

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-33498, organizations should immediately upgrade parse-server to version 8.6.55 or later, or 9.6.0-alpha.44 or later, where the vulnerability has been patched. For environments where immediate upgrade is not feasible, implementing network-level protections such as Web Application Firewalls (WAFs) to detect and block deeply nested or suspicious query patterns can reduce exposure. Rate limiting and IP reputation filtering can also help mitigate attack attempts. Monitoring parse-server logs for unusual query patterns or repeated requests with complex nested logical operators can provide early detection. Additionally, isolating parse-server instances behind VPNs or restricting access to trusted networks reduces the attack surface. Regularly reviewing and applying security updates from the parse-community project is essential to maintain protection against similar vulnerabilities.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.55 and 9.6.0-alpha.44, an attacker can send an unauthenticated HTTP request with a deeply nested query containing logical operators to permanently hang the Parse Server process. The server becomes completely unresponsive and must be manually restarted. This is a bypass of the fix for CVE-2026-32944. This issue has been patched in versions 8.6.55 and 9.6.0-alpha.44.

References

Community reviews

Loading reviews…