Skip to main content
VulnerabilityPublished

CVE-2026-33508: parse-server · Uncontrolled Recursion

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 9.6.0-alpha.45 or 8.6.56 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.45, 8.6.56
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.45 or 8.6.56; parse-community/parse-server to 8.6.56.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.45
Fixed in
  • 9.6.0-alpha.45
parse-communityparse-serverAffected
  • <8.6.56
Fixed in
  • 8.6.56
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.56
Fixed in
  • 8.6.56

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade Parse Server to version 8.6.56 or later, or 9.6.0-alpha.45 or later, where the vulnerability is patched. If upgrading is not immediately feasible, administrators should consider implementing network-level protections such as Web Application Firewalls (WAFs) or rate limiting to detect and block suspiciously complex or deeply nested subscription requests targeting the LiveQuery WebSocket endpoint. Monitoring CPU usage and WebSocket traffic patterns can help identify potential exploitation attempts. Additionally, configuring Parse Server to enforce strict requestComplexity.queryDepth limits and validating subscription queries before processing can reduce risk. Isolating Parse Server instances behind VPNs or restricting access to trusted networks can further limit exposure. Regularly reviewing and applying security updates from the parse-community project is essential to maintain protection against similar vulnerabilities.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.56 and 9.6.0, Parse Server's LiveQuery component does not enforce the requestComplexity.queryDepth configuration setting when processing WebSocket subscription requests. An attacker can send a subscription with deeply nested logical operators, causing excessive recursion and CPU consumption that degrades or disrupts service availability. This issue has been patched in versions 8.6.56 and 9.6.0

References

Community reviews

Loading reviews…