CVE-2026-33527: parse-server · Incorrect Authorization
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 9.6.0-alpha.48 or 8.6.57 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.48, 8.6.57
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.48 or 8.6.57; parse-community/parse-server to 8.6.57.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should upgrade parse-server to version 8.6.57 or later, or 9.6.0-alpha.48 or later, where the vulnerability is patched. Until upgrading, implement strict monitoring of session activity and anomalous session durations to detect potential abuse. Restrict access to the REST API to trusted users and enforce strong authentication mechanisms to reduce the risk of unauthorized session manipulation. Consider implementing additional server-side validation to reject updates to sensitive session fields from clients. Employ session management best practices such as short session lifetimes, regular session invalidation, and multi-factor authentication to mitigate the impact of persistent sessions. Review and audit session handling code and API permissions to ensure no other fields can be manipulated improperly. Finally, maintain an incident response plan that includes procedures for revoking sessions and responding to suspected session abuse.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.57 and 9.6.0, an authenticated user can overwrite server-generated session fields such as expiresAt and createdWith when updating their own session via the REST API. This allows bypassing the server's configured session lifetime policy, making a session effectively permanent. This issue has been patched in versions 8.6.57 and 9.6.0
References
- github.com/parse-community/parse-server/security/advisories/GHSA-jc39-686j-wp6q (opens in a new tab)
- github.com/parse-community/parse-server/pull/10263 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10264 (opens in a new tab)
- github.com/parse-community/parse-server/commit/26b628c8fb3cc79ea955374769eebcff6f8a8a73 (opens in a new tab)
- github.com/parse-community/parse-server/commit/ea68fc0b22a6056c9675149469ff57817f7cf984 (opens in a new tab)