CVE-2026-33558: Apache Kafka · DEPRECATED: Information Exposure Through Server Log Files
Affects Apache KafkaSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium · fixed in 3.9.2 : update Apache Kafka when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Kafka | Affected
| Fixed in– |
| Apache Software FoundationApache Kafka Clients | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.kafka:kafka-clientspkg:maven/Apache Software Foundation/org.apache.kafka:kafka-clientsOther threats | Affected
| Fixed in– |
Mavenorg.apache.kafka/kafka-clientspkg:maven/org.apache.kafka/kafka-clientsOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Kafka to version 3.9.2, 4.0.1, or later where this issue is fixed. Additionally, avoid enabling DEBUG log level in production environments unless necessary, as it exposes sensitive information in logs. Patch status is not explicitly confirmed in the advisory, but the vendor recommends upgrading to fixed versions.
Description
Information exposure vulnerability has been identified in Apache Kafka. The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are: * AlterConfigsRequest * AlterUserScramCredentialsRequest * ExpireDelegationTokenRequest * IncrementalAlterConfigsRequest * RenewDelegationTokenRequest * SaslAuthenticateRequest * createDelegationTokenResponse * describeDelegationTokenResponse * SaslAuthenticateResponse This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.