CVE-2026-33624: parse-server · Time-of-check Time-of-use (TOCTOU) Race Condition
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 2.1 Low : upgrade to 9.6.0-alpha.54 or 8.6.60 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.54, 8.6.60
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.54 or 8.6.60; parse-community/parse-server to 8.6.60.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade parse-server to version 8.6.60 or later, or 9.6.0-alpha.54 or later, where the race condition has been fixed. In addition to patching, administrators should monitor authentication logs for unusual patterns of concurrent login attempts using MFA recovery codes, which may indicate exploitation attempts. Implementing rate limiting or throttling on login endpoints can reduce the feasibility of rapid concurrent requests needed to exploit this vulnerability. Educate users on safeguarding their passwords and MFA recovery codes to prevent credential theft. Consider deploying additional anomaly detection systems to flag suspicious authentication behaviors. For environments where immediate patching is not feasible, temporarily disabling MFA recovery codes or enforcing stricter session management policies may reduce risk. Finally, ensure that incident response plans include procedures for handling potential MFA recovery code abuse.
Description
CVE-2026-33624 is a TOCTOU race condition vulnerability in parse-community's parse-server affecting versions prior to 8.6.60 and 9.6.0-alpha.54. An attacker with a user's password and a single MFA recovery code can exploit concurrent login requests to reuse the recovery code multiple times, bypassing its intended single-use restriction. Exploitation requires high privileges (user password), a valid recovery code, and the ability to send rapid concurrent requests. This flaw undermines MFA recovery code security but does not allow unauthorized access without credentials. The vulnerability has a low CVSS score (2.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-2299-ghjr-6vjp (opens in a new tab)
- github.com/parse-community/parse-server/pull/10275 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10276 (opens in a new tab)
- github.com/parse-community/parse-server/commit/5e70094250a36bfcc14ecd49592be2b94fba66ff (opens in a new tab)
- github.com/parse-community/parse-server/commit/fc3da35a81d5083b453e8967cabcc880f1a3bd0c (opens in a new tab)