Skip to main content
VulnerabilityPublished

CVE-2026-33627: parse-server · Information Exposure

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 9.6.0-alpha.55 or 8.6.61 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.55, 8.6.61
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.55 or 8.6.61; parse-community/parse-server to 8.6.61.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.55
Fixed in
  • 9.6.0-alpha.55
parse-communityparse-serverAffected
  • <8.6.61
Fixed in
  • 8.6.61
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.61
Fixed in
  • 8.6.61

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade parse-server to version 8.6.61 or later, or 9.6.0-alpha.55 or later, where the vulnerability is patched. Organizations should also implement strict session token management practices, including short token lifetimes, token revocation mechanisms, and monitoring for unusual session activity to reduce the risk of token theft. Employing additional layers of security such as IP whitelisting, anomaly detection, and device fingerprinting can help detect and prevent unauthorized use of stolen tokens. Reviewing and restricting access to the GET /users/me endpoint and ensuring that sensitive fields are properly sanitized in custom implementations can reduce exposure. Regular security audits and penetration testing focused on authentication flows are recommended to detect similar issues. Finally, educating users on securing their session tokens and MFA credentials is important to reduce the risk of token compromise.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.61 and 9.6.0, an authenticated user calling GET /users/me receives unsanitized auth data, including sensitive credentials such as MFA TOTP secrets and recovery codes. The endpoint internally uses master-level authentication for the session query, and the master context leaks through to the user data, bypassing auth adapter sanitization. An attacker who obtains a user's session token can extract MFA secrets to generate valid TOTP codes indefinitely. This issue has been patched in versions 8.6.61 and 9.6.0

References

Community reviews

Loading reviews…