CVE-2026-33636: pnggroup libpng · Out-of-bounds Read
Affects pnggroup libpngSource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 1.6.56 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.6.56
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade pnggroup libpng to 1.6.56.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pnggrouplibpng | Affected
| Fixed in
|
GitHubpnggroup/libpngpkg:github/pnggroup/libpngOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade libpng to version 1.6.56 or later, where this vulnerability is fixed. No other mitigations are indicated. Patch status is confirmed by the vendor's versioning information.
Description
An out-of-bounds read and write vulnerability exists in libpng versions 1.6.36 through 1.6.55 in the ARM/AArch64 Neon-optimized palette expansion code. This occurs when expanding 8-bit paletted rows to RGB or RGBA, where the Neon loop processes a final partial chunk without verifying input pixel boundaries, causing pointer underflow and memory corruption. The issue can be triggered by decoding attacker-controlled PNG files if Neon is enabled. Version 1.6.56 addresses this vulnerability.