Skip to main content
VulnerabilityPublished

CVE-2026-33738: LycheeOrg Lychee · Cross-site Scripting

Affects LycheeOrg LycheeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.5.3 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.5.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:H/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Lychee and lycheeorg/Lychee to 7.5.3.

Affected software

ProductAffectedFixed in
LycheeOrgLycheeAffected
  • <7.5.3
Fixed in
  • 7.5.3
GitHublycheeorg/Lycheepkg:github/lycheeorg/LycheeOther threatsAffected
  • <7.5.3
Fixed in
  • 7.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Lychee to version 7.5.3 or later, where the vulnerability is fixed by properly sanitizing the photo description field and rendering it safely. No other mitigation is required as the fix is official and available.

Description

Lychee versions prior to 7.5.3 contain a cross-site scripting (XSS) vulnerability in the photo description field. This field is stored without HTML sanitization and rendered unescaped in RSS, Atom, and JSON feed templates. The publicly accessible /feed endpoint allows any RSS reader to execute attacker-controlled JavaScript. The issue is fixed in version 7.5.3.

References

Community reviews

Loading reviews…