CVE-2026-7263: PHP · Improper Resource Shutdown or Release
Affects PHPSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 8.5.6 or 8.4.21 when convenient.
Data as of 7 Nov 2026, 23:24 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.5.6, 8.4.21
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/AU:Y/RE:M/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 10 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade PHP to 8.5.6 or 8.4.21.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PHP GroupPHP | Affected
| Fixed in
|
| PHP GroupPHP | Affected
| Fixed in
|
AI-suggested
A fix is available and included in PHP versions 8.4.21 and 8.5.6 and later. Users should apply these official updates as provided by their vendor or distribution, such as the Red Hat Enterprise Linux security update RHSA-2026:22649. There is no indication that additional mitigation steps beyond patching are required. Patch status is confirmed by the vendor advisory.
Description
In PHP versions 8.4.* before 8.4.21 and 8.5.* before 8.5.6, DOMNode::C14N() method may process the XML data incorrectly, causing a circular linked list in the data structure representing the XML document. This may cause subsequent processing of the XML document to enter infinite loop, causing denial of service in the processing application.
References
- github.com/php/php-src/security/advisories/GHSA-4jhr-8w89-j733 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-7263 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2468572 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-7263.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:22649 (opens in a new tab)