CVE-2026-3381: PMQS Compress::Raw::Zlib · Dependency on Vulnerable Third-Party Component
Affects PMQS Compress::Raw::ZlibSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.8 Critical.
Data as of 29 Oct 2026, 19:04 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PMQSCompress::Raw::Zlib | Affected
| Fixed in– |
GitHubCompress-Raw-Zlibpkg:github/Compress-Raw-ZlibOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately identify all systems and applications using Compress::Raw::Zlib versions up to 2.219. The primary mitigation is to upgrade to Compress::Raw::Zlib version 2.220 or later, which includes the updated and secure zlib 1.3.2 library. For environments where immediate upgrade is not feasible, consider isolating affected systems from untrusted networks and restricting network access to limit exposure. Implement network-level intrusion detection and prevention systems tuned to detect anomalous compression-related traffic patterns. Conduct thorough code audits to identify any custom usage of the vulnerable compression functions and apply patches or workarounds where possible. Maintain up-to-date backups and incident response plans to quickly recover from potential exploitation. Monitor security advisories for any emerging exploit code or additional patches related to this vulnerability. Engage with Perl module maintainers and security communities to stay informed about further developments.
Description
Compress::Raw::Zlib versions through 2.219 for Perl use potentially insecure versions of zlib. Compress::Raw::Zlib includes a copy of the zlib library. Compress::Raw::Zlib version 2.220 includes zlib 1.3.2, which addresses findings fron the 7ASecurity audit of zlib. The includes fixs for CVE-2026-27171.
References
- metacpan.org/release/PMQS/Compress-Raw-Zlib-2.221/source/Changes (opens in a new tab)
- zlib.net (opens in a new tab)
- github.com/madler/zlib (opens in a new tab)
- github.com/madler/zlib/releases/tag/v1.3.2 (opens in a new tab)
- 7asecurity.com/blog/2026/02/zlib-7asecurity-audit/ (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-27171 (opens in a new tab)
- github.com/pmqs/Compress-Raw-Zlib/issues/41 (opens in a new tab)