Skip to main content
VulnerabilityPublished

CVE-2026-34066: nimiq-blockchain · Improper Input Validation

Affects nimiq-blockchainSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.3.0 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nimiq-blockchain and github/nimiq/core-rs-albatross to 1.3.0.

Affected software

ProductAffectedFixed in
nimiqnimiq-blockchainAffected
  • <1.3.0
Fixed in
  • 1.3.0
crates.iogithub/nimiq/core-rs-albatrosspkg:cargo/github/nimiq/core-rs-albatrossOther threatsAffected
  • <1.3.0
Fixed in
  • 1.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade nimiq-blockchain to version 1.3.0 or later, where this vulnerability is patched. No known workarounds exist. Until the upgrade, nodes remain vulnerable to denial of service via malformed history data during sync.

Description

A vulnerability in nimiq-blockchain versions prior to 1.3.0 allows a remote peer to cause a panic via improper input validation in the HistoryStore component. Specifically, the function put_historic_txns uses an assert to enforce block number invariants, which can be violated by a malformed history list during history synchronization, leading to a denial of service. The issue is fixed in version 1.3.0. No known workarounds exist.

References

Community reviews

Loading reviews…