CVE-2026-34082: langgenius dify · Incorrect Authorization
Affects langgenius difySource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.13.1 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.13.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade dify and langgenius/dify to 1.13.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| langgeniusdify | Affected
| Fixed in
|
GitHublanggenius/difypkg:github/langgenius/difyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Dify to version 1.13.1 or later, where this authorization issue has been fixed. Since the vendor advisory states the issue is patched in 1.13.1, applying this official fix fully mitigates the vulnerability. No additional mitigations are indicated.
Description
CVE-2026-34082 is a medium severity vulnerability in the open-source LLM app development platform Dify (langgenius). Before version 1.13.1, the DELETE API endpoint for removing conversations lacks proper authorization checks, allowing any authenticated user to delete chat histories belonging to other users. This issue is fixed in version 1.13.1. The vulnerability is classified under CWE-863 (Incorrect Authorization) and CWE-284 (Improper Access Control).