CVE-2026-34084: PHPOffice PhpSpreadsheet · Deserialization of Untrusted Data
Affects PHPOffice PhpSpreadsheetSource CVE Database V5
Not known to be exploited · CVSS 9.2 Critical · fixed in 5.6.0 : patch PHPOffice PhpSpreadsheet as a priority.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.6.0, 3.10.4, 2.4.4 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade phpoffice/phpspreadsheet to 5.6.0, 3.10.4, 2.4.4 or 2.1.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PHPOfficePhpSpreadsheet | Affected
| Fixed in– |
Packagistphpoffice/phpspreadsheetpkg:composer/phpoffice/phpspreadsheetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PhpSpreadsheet to a fixed version: 1.30.3, 2.1.15, 2.4.4, 3.10.4, or 5.6.0 or later. Avoid passing user-controlled input directly to IOFactory::load() without validation. Patch status is confirmed fixed in these versions. No vendor advisory content contradicts this remediation.
Description
PhpSpreadsheet is a library for reading and writing spreadsheet files. In versions 1.30.2 and earlier, 2.0.0 through 2.1.14, 2.2.0 through 2.4.3, 3.3.0 through 3.10.3, and 4.0.0 through 5.5.0, when the filename argument to IOFactory::load() is user-controlled, an attacker can supply a PHP stream wrapper path (such as phar://, ftp://, or ssh2.sftp://) that passes the is_file() check in File::assertFile(). The phar:// wrapper triggers deserialization of the PHAR metadata, which can lead to remote code execution if a suitable gadget chain is available in the application. The ftp:// and ssh2.sftp:// wrappers can be used for server-side request forgery. This issue has been fixed in versions 1.30.3, 2.1.15, 2.4.4, 3.10.4, and 5.6.0.