Skip to main content
CVE-2025-54370VulnerabilityPublished

CVE-2025-54370: PHPOffice PhpSpreadsheet · Server-Side Request Forgery (SSRF)

Affects PHPOffice PhpSpreadsheetSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 1.30.0 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.30.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade PHPOffice PhpSpreadsheet to 1.30.0.

Affected software

ProductAffectedFixed in
PHPOffice PhpSpreadsheetAffected
  • <1.30.0
Fixed in
  • 1.30.0

AI-suggested

European organizations should immediately verify the versions of PhpSpreadsheet in use and upgrade to the patched versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, or 5.0.0 as applicable. Beyond upgrading, organizations should implement strict input validation and sanitization on any user-supplied data that is processed by PhpSpreadsheet, especially data that influences HTML rendering or file paths. Network-level controls should be enforced to restrict outbound HTTP requests from web servers to only necessary destinations, using egress filtering and web application firewalls (WAFs) configured to detect and block SSRF patterns. Additionally, internal services should be segmented and protected with strong authentication and authorization controls to limit the impact of any SSRF exploitation. Logging and monitoring should be enhanced to detect unusual outbound requests from web servers, which may indicate exploitation attempts. Finally, organizations should conduct security assessments and penetration testing focused on SSRF vectors in their PHP applications to identify and remediate any residual risks.

Description

PhpOffice/PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0, SSRF can occur when a processed HTML document is read and displayed in the browser. The vulnerability lies in the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class, where a crafted string from the user is passed to the HTML reader. This issue has been patched in versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0.

References

Community reviews

Loading reviews…