Skip to main content
VulnerabilityPublished Updated

CVE-2026-34085: fontconfig · Off-by-one Error

Affects fontconfigSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.17.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.17.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade fontconfig and fontconfig/fontconfig to 2.17.1.

Affected software

ProductAffectedFixed in
fontconfig projectfontconfigAffected
  • <2.17.1
Fixed in
  • 2.17.1
GitHubfontconfig/fontconfigpkg:github/fontconfig/fontconfigOther threatsAffected
  • <2.17.1
Fixed in
  • 2.17.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until then, consider limiting exposure by restricting access to affected fontconfig components where feasible.

Description

CVE-2026-34085 is an off-by-one error vulnerability in the fontconfig library before version 2.17.1. The flaw occurs in the allocation logic during sfnt capability handling within the FcFontCapabilities function in fcfreetype.c, causing a one-byte out-of-bounds write. This vulnerability can lead to a crash or potentially allow code execution. The CVSS score is 5.9, indicating a medium severity level. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…