CVE-2026-34215: parse-server · Information Exposure
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 9.7.0-alpha.7 or 8.6.63 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.7.0-alpha.7, 8.6.63
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade parse-server to 9.7.0-alpha.7 or 8.6.63; parse-server to 8.6.63.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade parse-server to version 8.6.63 or later, or to 9.7.0-alpha.7 or later, where this vulnerability has been patched. No other mitigations are indicated by the vendor advisory.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.63 and 9.7.0-alpha.7, the verify password endpoint returns unsanitized authentication data, including MFA TOTP secrets, recovery codes, and OAuth access tokens. An attacker who knows a user's password can extract the MFA secret to generate valid MFA codes, defeating multi-factor authentication protection. This issue has been patched in versions 8.6.63 and 9.7.0-alpha.7.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-wp76-gg32-8258 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10323 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10324 (opens in a new tab)
- github.com/parse-community/parse-server/commit/770be8647424d92f5425c41fa81065ffbbb171ed (opens in a new tab)
- github.com/parse-community/parse-server/commit/a1d4e7b12a12f16d3870dbee582a36765858e94c (opens in a new tab)