Skip to main content
VulnerabilityPublished

CVE-2026-34234: Ctrlpanel-gg panel · OS Command Injection

Affects Ctrlpanel-gg panelSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 10.0 Critical : upgrade to 1.2.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
3.2% chance of exploitation in 30 days – higher than 88% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade panel and ctrlpanel-gg/panel to 1.2.0.

Affected software

ProductAffectedFixed in
Ctrlpanel-ggpanelAffected
  • <1.2.0
Fixed in
  • 1.2.0
GitHubctrlpanel-gg/panelpkg:github/ctrlpanel-gg/panelOther threatsAffected
  • <1.2.0
Fixed in
  • 1.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade CtrlPanel to version 1.2.0 or later, where this vulnerability has been fixed. No other official remediation or temporary fixes are documented. Patch status is not explicitly stated but the vendor has released a fixed version, so applying this update is the recommended action.

Description

CtrlPanel is open-source billing software for hosting providers. In versions 1.1.1 and prior, the web-based installer (public/installer/index.php) is vulnerable to unauthenticated Remote Code Execution (RCE) because it performs the install.lock check only after including and executing form handler files, leaving installer endpoints reachable on already-installed instances. The handlers also pass unsanitized user input directly into shell commands, allowing an attacker to submit crafted requests that execute arbitrary commands on the server. The vulnerability stems from two combined weaknesses: (1) premature form handler execution before the lock file gate, and (2) unsafe use of user input in shell command construction. This issue is reported to be actively exploited in the wild. The issue has been fixed in version 1.2.0.

References

Community reviews

Loading reviews…