CVE-2026-34363: parse-server · Race Condition
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 9.7.0-alpha.9 or 8.6.65 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.7.0-alpha.9, 8.6.65
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.7.0-alpha.9 or 8.6.65; parse-server to 8.6.65.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade all parse-server deployments to version 8.6.65 or later, or 9.7.0-alpha.9 or later, where the race condition is patched. If immediate upgrading is not feasible, consider disabling LiveQuery subscriptions on classes with protected fields or afterEvent triggers to prevent concurrent access issues. Implement additional application-level access controls and data validation to detect and block unauthorized data exposure. Monitor logs for unusual LiveQuery subscription patterns or data anomalies that may indicate exploitation attempts. Conduct thorough testing of Cloud Code triggers to ensure they do not inadvertently share mutable state. Engage in secure coding practices to avoid shared mutable state in asynchronous event handlers. Finally, maintain up-to-date backups and incident response plans to quickly address any data breaches resulting from exploitation.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.65 and 9.7.0-alpha.9, when multiple clients subscribe to the same class via LiveQuery, the event handlers process each subscriber concurrently using shared mutable objects. The sensitive data filter modifies these shared objects in-place, so when one subscriber's filter removes a protected field, subsequent subscribers may receive the already-filtered object. This can cause protected fields and authentication data to leak to clients that should not see them, or cause clients that should see the data to receive an incomplete object. Additionally, when an afterEvent Cloud Code trigger is registered, one subscriber's trigger modifications can leak to other subscribers through the same shared mutable state. Any Parse Server deployment using LiveQuery with protected fields or afterEvent triggers is affected when multiple clients subscribe to the same class. This issue has been patched in versions 8.6.65 and 9.7.0-alpha.9.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-m983-v2ff-wq65 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10330 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10331 (opens in a new tab)
- github.com/parse-community/parse-server/commit/5834e29234593addaa0251a85f572ad4f376320b (opens in a new tab)
- github.com/parse-community/parse-server/commit/776c71c3078e77d38c94937f463741793609d055 (opens in a new tab)