CVE-2026-34371: danny-avila LibreChat · Path Traversal
Affects danny-avila LibreChatSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 0.8.4 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.4
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade LibreChat and danny-avila/LibreChat to 0.8.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| danny-avilaLibreChat | Affected
| Fixed in
|
GitHubdanny-avila/LibreChatpkg:github/danny-avila/LibreChatOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade LibreChat to version 0.8.4 or later, where this vulnerability is fixed. Patch status is not explicitly confirmed beyond the statement that the issue is fixed in 0.8.4, so checking the vendor's official release notes is recommended for current remediation guidance.
Description
CVE-2026-34371 is a path traversal vulnerability in LibreChat versions prior to 0.8.4. The issue arises because the application trusts the filename returned by the execute_code sandbox without sanitization when saving code-generated artifacts. This allows an attacker who can trigger execute_code to write arbitrary files on the server with the privileges of the LibreChat server user. The vulnerability is fixed in version 0.8.4.