Skip to main content
VulnerabilityPublished

CVE-2026-34373: parse-server · Origin Validation Error

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 9.7.0-alpha.10 or 8.6.66 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.7.0-alpha.10, 8.6.66
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.7.0-alpha.10 or 8.6.66; parse-community/parse-server to 8.6.66.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.7.0-alpha.10
Fixed in
  • 9.7.0-alpha.10
parse-communityparse-serverAffected
  • <8.6.66
Fixed in
  • 8.6.66
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.66
Fixed in
  • 8.6.66

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade parse-server instances to version 8.6.66 or later, or 9.7.0-alpha.10 or later, where the vulnerability is patched.
  2. Review and enforce strict CORS policies on the server side, ensuring that only trusted origins are allowed to interact with the GraphQL API.
  3. Implement Content Security Policy (CSP) headers on client applications to restrict the domains that can execute scripts and make cross-origin requests.
  4. Monitor and audit GraphQL API usage logs for unusual cross-origin requests or suspicious activity.
  5. Educate users about the risks of visiting untrusted websites while authenticated to sensitive services.
  6. If upgrading immediately is not possible, consider disabling the GraphQL API endpoint or restricting its network exposure until patched.
  7. Employ web application firewalls (WAFs) that can detect and block suspicious cross-origin requests targeting the GraphQL endpoint.
  8. Conduct regular security assessments and penetration testing focusing on CORS and API endpoint configurations.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.66 and 9.7.0-alpha.10, the GraphQL API endpoint does not respect the allowOrigin server option and unconditionally allows cross-origin requests from any website. This bypasses origin restrictions that operators configure to control which websites can interact with the Parse Server API. The REST API correctly enforces the configured allowOrigin restriction. This issue has been patched in versions 8.6.66 and 9.7.0-alpha.10.

References

Community reviews

Loading reviews…