CVE-2026-3455: mailparser · Cross-site Scripting (XSS)
Affects mailparserSource CVE Database V5
Public exploit available · CVSS 5.1 Medium : upgrade to 3.9.3 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 3 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade mailparser to 3.9.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| mailparser | Affected
| Fixed in
|
npmmailparserpkg:npm/mailparserOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-3455, organizations should immediately upgrade mailparser to version 3.9.3 or later, where the vulnerability has been fixed. Beyond patching, it is recommended to implement strict input validation and sanitization on all email content before rendering it in browsers. Employ Content Security Policy (CSP) headers to restrict the execution of inline scripts and limit the sources from which scripts can be loaded. Additionally, consider disabling or limiting HTML rendering of email content where feasible, or use safer rendering libraries that automatically sanitize inputs. Educate users about the risks of interacting with suspicious emails and implement email filtering solutions to detect and block malicious payloads. Regularly audit and monitor email processing systems for unusual activity or signs of exploitation attempts. Finally, maintain an up-to-date inventory of software dependencies to ensure timely application of security patches.
Description
Versions of the package mailparser before 3.9.3 are vulnerable to Cross-site Scripting (XSS) via the textToHtml() function due to the improper sanitisation of URLs in the email content. An attacker can execute arbitrary scripts in victim browsers by adding extra quote " to the URL with embedded malicious JavaScript code.
References
- security.snyk.io/vuln/SNYK-JS-MAILPARSER-15204032 (opens in a new tab)
- github.com/nodemailer/mailparser/commit/921a67df4cfb38f0b411037d7b26fbd4d5411b08 (opens in a new tab)
- gist.github.com/hayageek/7fcb225e3b1ea9a341d560403fbb585a (opens in a new tab)
- github.com/nodemailer/mailparser/issues/412 (opens in a new tab)