CVE-2026-34988: bytecodealliance wasmtime · Memory Buffer Overflow
Affects bytecodealliance wasmtimeSource CVE Database V5
Not known to be exploited · CVSS 2.3 Low · fixed in 44.0.1 : update bytecodealliance wasmtime when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 44.0.1, 42.0.2, 36.0.7 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade wasmtime to 44.0.1, 42.0.2 or 36.0.7; bytecodealliance/wasmtime to 43.0.1 or 42.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| bytecodealliancewasmtime | Affected
| Fixed in
|
| bytecodealliancewasmtime | Affected
| Fixed in
|
| bytecodealliancewasmtime | Affected
| Fixed in
|
crates.iobytecodealliance/wasmtimepkg:cargo/bytecodealliance/wasmtimeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Wasmtime versions 36.0.7, 42.0.2, and 43.0.1. Users should upgrade to one of these fixed versions to remediate the issue. Wasmtime's default configuration and default pooling allocator settings are not vulnerable. If upgrading is not immediately possible, ensure that the pooling allocator is not used with Config::memory_guard_size set to 0, Config::memory_reservation less than 4GiB, and max_memory_size equal to memory_reservation simultaneously, as these conditions enable the vulnerability. Patch status is not explicitly confirmed beyond the fixed versions; check the vendor advisory for the latest remediation guidance.
Description
Wasmtime is a runtime for WebAssembly. From 28.0.0 to before 36.0.7, 42.0.2, and 43.0.1, Wasmtime's implementation of its pooling allocator contains a bug where in certain configurations the contents of linear memory can be leaked from one instance to the next. The implementation of resetting the virtual memory permissions for linear memory used the wrong predicate to determine if resetting was necessary, where the compilation process used a different predicate. This divergence meant that the pooling allocator incorrectly deduced at runtime that resetting virtual memory permissions was not necessary while compile-time determine that virtual memory could be relied upon. The pooling allocator must be in use, Config::memory_guard_size configuration option must be 0, Config::memory_reservation configuration must be less than 4GiB, and pooling allocator must be configured with max_memory_size the same as the memory_reservation value in order to exploit this vulnerability. If all of these conditions are applicable then when a linear memory is reused the VM permissions of the previous iteration are not reset. This means that the compiled code, which is assuming out-of-bounds loads will segfault, will not actually segfault and can read the previous contents of linear memory if it was previously mapped. This represents a data leakage vulnerability between guest WebAssembly instances which breaks WebAssembly's semantics and additionally breaks the sandbox that Wasmtime provides. Wasmtime is not vulnerable to this issue with its default settings, nor with the default settings of the pooling allocator, but embeddings are still allowed to configure these values to cause this vulnerability. This vulnerability is fixed in 36.0.7, 42.0.2, and 43.0.1.