Skip to main content
VulnerabilityPublished Updated

CVE-2026-3520: expressjs multer · Uncontrolled Recursion

Affects expressjs multerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 2.1.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade expressjs multer to 2.1.1.

Affected software

ProductAffectedFixed in
expressjsmulterAffected
  • <2.1.1
Fixed in
  • 2.1.1
npmmulterpkg:npm/multerOther threatsAffected
  • <2.1.1
Fixed in
  • 2.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade multer to version 2.1.1 or later to remediate this vulnerability. No known workarounds are available. Since this is not a cloud service, remediation depends on user action to update the software. Check the vendor advisories at Red Hat for any additional guidance.

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.

References

Community reviews

Loading reviews…