Skip to main content
VulnerabilityPublished

CVE-2026-35212: opencti · Cross-site Scripting

Affects openctiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 7.260227.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.260227.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade opencti and opencti-platform/opencti to 7.260227.0.

Affected software

ProductAffectedFixed in
OpenCTI-PlatformopenctiAffected
  • <7.260227.0
Fixed in
  • 7.260227.0
GitHubopencti-platform/openctipkg:github/opencti-platform/openctiOther threatsAffected
  • <7.260227.0
Fixed in
  • 7.260227.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenCTI-Platform opencti version 7.260227.0. Users should upgrade to this version or later to remediate the vulnerability. Until upgrading, exercise caution when sharing or ingesting untrusted STIX or email-message observable data.

Description

OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Versions prior to 7.260227.0 are vulnerable to XSS in the rendering of email-message observable body data. The content of the body field isn't appropriately sanitized when being rendered. Does require user interaction but could be exploited by someone sharing stix or any of the ingester. This could lead to CSRF and then large scale session theft. Version 7.260227.0 contains a fix.

References

Community reviews

Loading reviews…